PHP8.0でワードプレスに重大なエラーが出るプラグイン

こんにちは、minoruです。

ワードプレスを使っているサーバーがPHP8.0に対応したので、早速PHPを7.xからアップグレードしたところ、ワードプレスの管理画面に入れなくなりました!

ワードプレス5.2以降では、致命的なエラーが出た場合には管理者のメールにお知らせが届くのですが、その通知メールによるとどうやらプラグインが原因。

「Search Regex」という記事内の文字を一括で検索・置換できるプラグイン。

しかし、管理画面にログインできないのでFTPソフトを使ってワードプレスを格納しているフォルダに入って行き、「wp-content/plugins/」の中にある「Search Regex」のフォルダを丸ごと削除したら解決しました。

「Search Regex」便利だったので、プラグインの改善を待ちましょうか。それまで他のワードプレスサイトはPHP8.0にするべきかどうか…迷う。

ツイッターはじめました!まだまだフォロワーさんが少なくてさみしいので、ぜひフォローお願いしまーす!

シェアする

  • このエントリーをはてなブックマークに追加

フォローする